package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ed\d+|[a-zA-Z]+|\d{4})`)
var str = `___file___name___2000___ed2___1___2___3
DIFFERENT+FILENAME+(2000)+1+2+3+ed10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}