const regex = /(ed\d+|[a-zA-Z]+|\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ed\\d+|[a-zA-Z]+|\\d{4})', 'gm')
const str = `___file___name___2000___ed2___1___2___3
DIFFERENT+FILENAME+(2000)+1+2+3+ed10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}