import re
regex = re.compile(r"(ed\d+|[a-zA-Z]+|\d{4})", flags=re.MULTILINE)
test_str = ("___file___name___2000___ed2___1___2___3\n"
"DIFFERENT+FILENAME+(2000)+1+2+3+ed10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")