use strict;
my $str = 'No 1 And Your Bird Can Sing (4)
No 2 Baby, You\'re a Rich Man (5)
No 3 Blue Jay Way S
No 4 Everybody\'s Got Something to Hide Except Me and My Monkey (1)';
my $regex = qr/^No (?<no>\d{1,3}) (?<title>(?:[^(\r\n]+|\((?!\d\)))+)(?:\((?<weeks>\d)\))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}