$re = '/^No (?<no>\d{1,3}) (?<title>(?:[^(\r\n]+|\((?!\d\)))+)(?:\((?<weeks>\d)\))?/m';
$str = 'No 1 And Your Bird Can Sing (4)
No 2 Baby, You\'re a Rich Man (5)
No 3 Blue Jay Way S
No 4 Everybody\'s Got Something to Hide Except Me and My Monkey (1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);