import re
regex = re.compile(r"^No (?<no>\d{1,3}) (?<title>(?:[^(\r\n]+|\((?!\d\)))+)(?:\((?<weeks>\d)\))?", flags=re.MULTILINE)
test_str = ("No 1 And Your Bird Can Sing (4)\n"
"No 2 Baby, You're a Rich Man (5)\n"
"No 3 Blue Jay Way S\n"
"No 4 Everybody's Got Something to Hide Except Me and My Monkey (1)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")