import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(ge\\-[0-9]{1,2}\\/[0-9]{1,2}\\/[0-9]{1,2}([\\.]?[0-9]{1,2})?)(\\s+)(\\w*)(\\s*)(\\w+(\\-)?\\w+)(\\s*)(\\w+(\\-)?\\w+$)?";
final String string = "--- JUNOS 20.4R1.12 Kernel 32-bit JNPR-11.0-20201028.e1cef1d_buil\n\n"
+ "{master:0}\n"
+ "adminl2j@child-ex2300-24t> \n"
+ " dollar, euro, pound\n"
+ "{master:0}\n"
+ "adminl2j@child-ex2300-24t> show interfaces ge-0/0/0 terse \n"
+ "Interface Admin Link Proto Local Remote\n"
+ "ge-0/0/0 up AdminPort-Down \n"
+ "ge-1/1/1 uP HighStatus eth-switch\n"
+ "ge-0/0/88.12 uP High-Status eth-switch\n"
+ "ge-0/0/22 uP High-Status eth-switch\n\n"
+ "ge-20/11/0.0 up up protocol3\n\n"
+ "{master:0}\n"
+ "adminl2j@child-ex2300-24t> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}