import re
regex = re.compile(r"^(ge\-[0-9]{1,2}\/[0-9]{1,2}\/[0-9]{1,2}([\.]?[0-9]{1,2})?)(\s+)(\w*)(\s*)(\w+(\-)?\w+)(\s*)(\w+(\-)?\w+$)?", flags=re.MULTILINE)
test_str = ("--- JUNOS 20.4R1.12 Kernel 32-bit JNPR-11.0-20201028.e1cef1d_buil\n\n"
"{master:0}\n"
"adminl2j@child-ex2300-24t> \n"
" dollar, euro, pound\n"
"{master:0}\n"
"adminl2j@child-ex2300-24t> show interfaces ge-0/0/0 terse \n"
"Interface Admin Link Proto Local Remote\n"
"ge-0/0/0 up AdminPort-Down \n"
"ge-1/1/1 uP HighStatus eth-switch\n"
"ge-0/0/88.12 uP High-Status eth-switch\n"
"ge-0/0/22 uP High-Status eth-switch\n\n"
"ge-20/11/0.0 up up protocol3\n\n"
"{master:0}\n"
"adminl2j@child-ex2300-24t> ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")