$re = '/(?<=Pet=)\w+/m';
$str = 'Owner=John Pet=Dog City=NY
Owner=Steve Pet=Cat City=LA
Owner=Paul Pet=Hamster City=LS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);