package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:NIP )[0-9-]{13}`)
var str = `16 NIP 712-10-08-323 2020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}