$re = '/(?:NIP )[0-9-]{13}/m';
$str = '16 NIP 712-10-08-323 2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);