const regex = /(?:NIP )[0-9-]{13}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:NIP )[0-9-]{13}', 'gm')
const str = `16 NIP 712-10-08-323 2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}