#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\d,.])(?:\d{1,3}(?:(?=([.,]))(?:\1\d{3})*)?|\d+)(?:(?!\1)[.,]\d{1,2})?(?![,.\d])"
Local $sString = "0,1" & @CRLF & _
"1.234,01" & @CRLF & _
"1234,10" & @CRLF & _
"1234,10a" & @CRLF & _
"123,456,789.10" & @CRLF & _
"123.456.789,10" & @CRLF & _
"50" & @CRLF & _
"50000" & @CRLF & _
"50,000,000" & @CRLF & _
"50000,7" & @CRLF & _
"50000.7" & @CRLF & _
"1234,1" & @CRLF & _
"" & @CRLF & _
",1" & @CRLF & _
"1," & @CRLF & _
"1234,100" & @CRLF & _
"123,456.789,10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")