$re = '/(?<![\d,.])(?:\d{1,3}(?:(?=([.,]))(?:\1\d{3})*)?|\d+)(?:(?!\1)[.,]\d{1,2})?(?![,.\d])/m';
$str = '0,1
1.234,01
1234,10
1234,10a
123,456,789.10
123.456.789,10
50
50000
50,000,000
50000,7
50000.7
1234,1
,1
1,
1234,100
123,456.789,10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);