import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\d,.])(?:\\d{1,3}(?:(?=([.,]))(?:\\1\\d{3})*)?|\\d+)(?:(?!\\1)[.,]\\d{1,2})?(?![,.\\d])";
final String string = "0,1\n"
+ "1.234,01\n"
+ "1234,10\n"
+ "1234,10a\n"
+ "123,456,789.10\n"
+ "123.456.789,10\n"
+ "50\n"
+ "50000\n"
+ "50,000,000\n"
+ "50000,7\n"
+ "50000.7\n"
+ "1234,1\n\n"
+ ",1\n"
+ "1,\n"
+ "1234,100\n"
+ "123,456.789,10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}