package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)took:\s+(?<took>[^ ]+)`)
var str = `slow query: 'FOR s IN abcdef FILTER LOWER(ghijk) == '123456789' LET serviceId = lmno FOR v IN pqrst GRAPH uvw_xyz RETURN v', bind vars: {}, took: 5.384533 s`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}