$re = '/took:\s+(?<took>[^ ]+)/m';
$str = 'slow query: \'FOR s IN abcdef FILTER LOWER(ghijk) == \'123456789\' LET serviceId = lmno FOR v IN pqrst GRAPH uvw_xyz RETURN v\', bind vars: {}, took: 5.384533 s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);