re = /took:\s+(?<took>[^ ]+)/m
str = 'slow query: \'FOR s IN abcdef FILTER LOWER(ghijk) == \'123456789\' LET serviceId = lmno FOR v IN pqrst GRAPH uvw_xyz RETURN v\', bind vars: {}, took: 5.384533 s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end