$re = '/\s*define\(\s*([\'"])([^\1]+)\1\s*,\s*([\'"])([^\3]*)\3\s*\);/';
$str = 'define(\'DB_HOST\', \'test\');';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);