using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([AC-FHKNPRTV-Y]\d{2}|D6W)[0-9AC-FHKNPRTV-Y]{4}";
string input = @"D6W1234
A230984
D00AV92
Y631FHK
A000000
D44N4X4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}