re = /([AC-FHKNPRTV-Y]\d{2}|D6W)[0-9AC-FHKNPRTV-Y]{4}/m
str = 'D6W1234
A230984
D00AV92
Y631FHK
A000000
D44N4X4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end