package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([AC-FHKNPRTV-Y]\d{2}|D6W)[0-9AC-FHKNPRTV-Y]{4}`)
var str = `D6W1234
A230984
D00AV92
Y631FHK
A000000
D44N4X4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}