#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/dev\/sd[a-z][a-z]?(?<!\/dev\/sda)"
Local $sString = "/dev/sda" & @CRLF & _
"/dev/sdb" & @CRLF & _
"/dev/sdc" & @CRLF & _
"/dev/sdd" & @CRLF & _
"/dev/sde" & @CRLF & _
"/dev/sdaa" & @CRLF & _
"/dev/sdab" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)