import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/dev\\/sd[a-z][a-z]?(?<!\\/dev\\/sda)";
final String string = "/dev/sda\n"
+ "/dev/sdb\n"
+ "/dev/sdc\n"
+ "/dev/sdd\n"
+ "/dev/sde\n"
+ "/dev/sdaa\n"
+ "/dev/sdab\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}