using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/dev\/sd[a-z][a-z]?(?<!\/dev\/sda)";
string substitution = @"";
string input = @"/dev/sda
/dev/sdb
/dev/sdc
/dev/sdd
/dev/sde
/dev/sdaa
/dev/sdab
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}