import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?# Piece Placement Section)(?<PiecePlacement>((?<RankItem>[pnbrqkPNBRQK1-8]{1,8})\\/?){8})\n"
+ "(?# Section Separator)\\s+\n"
+ "(?# Side To Move Section) (?<SideToMove>b|w)\n"
+ "(?# Section Separator)\\s+\n"
+ "(?# Castling Ability) (?<Castling>-|K?Q?k?q)\n"
+ "(?# Section Separator)\\s+\n"
+ "(?# En passant) (?<EnPassant>-|[a-h][3-6])\n"
+ "(?# Section Separator)\\s+\n"
+ "(?# Half Move Clock) (?<HalfMoveClock>\\d+)\n"
+ "(?# Section Separator)\\s+\n"
+ "(?# Full Move Number) (?<FullMoveNumber>\\d+)\n"
+ "\\s*\n"
+ "$";
final String string = "rnbqkbnr/pp1ppppp/8/2p5/4P3/5N2/PPPP1PPP/RNBQKB1R b KQkq - 1 2";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}