// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)^
(?# Piece Placement Section)(?<PiecePlacement>((?<RankItem>[pnbrqkPNBRQK1-8]{1,8})\/?){8})
(?# Section Separator)\s+
(?# Side To Move Section) (?<SideToMove>b|w)
(?# Section Separator)\s+
(?# Castling Ability) (?<Castling>-|K?Q?k?q)
(?# Section Separator)\s+
(?# En passant) (?<EnPassant>-|[a-h][3-6])
(?# Section Separator)\s+
(?# Half Move Clock) (?<HalfMoveClock>\d+)
(?# Section Separator)\s+
(?# Full Move Number) (?<FullMoveNumber>\d+)
\s*
$").unwrap();
let string = "rnbqkbnr/pp1ppppp/8/2p5/4P3/5N2/PPPP1PPP/RNBQKB1R b KQkq - 1 2";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}