import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\\\rtf1\\\\ansi\\\\ansicpg1252(?:.|[\\r\\n]+)*\\{\\\\\\*\\\\listtable";
final String string = "{\\rtf1\\ansi\\ansicpg1252\n"
+ "\\deff0{\\fonttbl{\\f0\\froman\\fcharset0 Times New Roman;}{\\f1\\froman\\fcharset0 HELVETICA;}{\\f2\\froman\\fcharset0 Arial;}{\\f3\\froman\\fcharset0 unknown;}{\\f4\\froman\\fcharset0 HELVETICA-BOLD;}{\\f5\\froman\\fcharset0 Helvetica;}}\n"
+ "{\\colortbl\\red0\\green0\\blue0;\\red255\\green255\\blue255;\\red244\\green245\\blue255;\\red254\\green182\\blue230;\\red0\\green0\\blue255;}\n"
+ "{\\stylesheet \n"
+ "{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}\n"
+ "{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}\n"
+ "{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}\n"
+ "{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}\n"
+ "}\n"
+ "{\\*\\listtable\n"
+ "{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}\n"
+ "{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}\n"
+ "{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}\n"
+ "{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}\n"
+ "}\n"
+ "{\\*\\listtable\n"
+ "}\n"
+ "{\\*\\listoverridetable\n"
+ "}\n"
+ "{\\*\\generator iText 2.1.2 (by lowagie.com)}\n"
+ "{\\info}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}