# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{\\rtf1\\ansi\\ansicpg1252(?:.|[\r\n]+)*\{\\\*\\listtable"
test_str = ("{\\rtf1\\ansi\\ansicpg1252\n"
"\\deff0{\\fonttbl{\\f0\\froman\\fcharset0 Times New Roman;}{\\f1\\froman\\fcharset0 HELVETICA;}{\\f2\\froman\\fcharset0 Arial;}{\\f3\\froman\\fcharset0 unknown;}{\\f4\\froman\\fcharset0 HELVETICA-BOLD;}{\\f5\\froman\\fcharset0 Helvetica;}}\n"
"{\\colortbl\\red0\\green0\\blue0;\\red255\\green255\\blue255;\\red244\\green245\\blue255;\\red254\\green182\\blue230;\\red0\\green0\\blue255;}\n"
"{\\stylesheet \n"
"{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}\n"
"{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}\n"
"{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}\n"
"{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}\n"
"}\n"
"{\\*\\listtable\n"
"{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}\n"
"{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}\n"
"{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}\n"
"{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}\n"
"}\n"
"{\\*\\listtable\n"
"}\n"
"{\\*\\listoverridetable\n"
"}\n"
"{\\*\\generator iText 2.1.2 (by lowagie.com)}\n"
"{\\info}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.