// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{\\rtf1\\ansi\\ansicpg1252(?:.|[\r\n]+)*\{\\\*\\listtable").unwrap();
let string = "{\\rtf1\\ansi\\ansicpg1252
\\deff0{\\fonttbl{\\f0\\froman\\fcharset0 Times New Roman;}{\\f1\\froman\\fcharset0 HELVETICA;}{\\f2\\froman\\fcharset0 Arial;}{\\f3\\froman\\fcharset0 unknown;}{\\f4\\froman\\fcharset0 HELVETICA-BOLD;}{\\f5\\froman\\fcharset0 Helvetica;}}
{\\colortbl\\red0\\green0\\blue0;\\red255\\green255\\blue255;\\red244\\green245\\blue255;\\red254\\green182\\blue230;\\red0\\green0\\blue255;}
{\\stylesheet
{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}
{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}
{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}
{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}
}
{\\*\\listtable
{\\style\\s0 \\ql\\fi0\\li0\\ri0\\f2\\fs24\\cf0 Normal;}
{\\style\\s3 \\ql\\fi0\\li0\\ri0\\f2\\fs26\\b\\cf0 heading 3;}
{\\style\\s2 \\ql\\fi0\\li0\\ri0\\f2\\fs28\\b\\i\\cf0 heading 2;}
{\\style\\s1 \\ql\\fi0\\li0\\ri0\\f2\\fs32\\b\\cf0 heading 1;}
}
{\\*\\listtable
}
{\\*\\listoverridetable
}
{\\*\\generator iText 2.1.2 (by lowagie.com)}
{\\info}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}