const regex = /\bab\w*\W*\sand\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bab\\w*\\W*\\sand\\b', 'gm')
const str = `abcd, of regex is not my cup of tea and coffee , but abcd - and efgh of JS are my whisky`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}