$re = '/\bab\w*\W*\sand\b/m';
$str = 'abcd, of regex is not my cup of tea and coffee , but abcd - and efgh of JS are my whisky';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);