re = /\bab\w*\W*\sand\b/m
str = 'abcd, of regex is not my cup of tea and coffee , but abcd - and efgh of JS are my whisky'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end