import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?!.*([ACD]).*\\1)(?!(?>.*?B){3})(?>[A-D] ){2}[A-D]$";
final String string = "A B C\n"
+ "A B B\n"
+ "B C B\n"
+ "D A B\n"
+ "A A B\n"
+ "B B B\n"
+ "B C C\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}