const regex = /(?m)^(?!.*([ACD]).*\1)(?!(?>.*?B){3})(?>[A-D] ){2}[A-D]$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(?!.*([ACD]).*\\1)(?!(?>.*?B){3})(?>[A-D] ){2}[A-D]$', 'g')
const str = `A B C
A B B
B C B
D A B
A A B
B B B
B C C
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}