re = /(?m)^(?!.*([ACD]).*\1)(?!(?>.*?B){3})(?>[A-D] ){2}[A-D]$/
str = 'A B C
A B B
B C B
D A B
A A B
B B B
B C C
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end