using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[abcd][01][01]";
string input = @"d00ba11c01d10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}