$re = '/[abcd][01][01]/m';
$str = 'd00ba11c01d10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);