package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[abcd][01][01]`)
var str = `d00ba11c01d10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}