using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!:\/\/)([a-zA-Z0-9-_]+\.)*[a-zA-Z0-9][a-zA-Z0-9-_]+\.[a-zA-Z]{2,11}";
string input = @"0,NODE_ENV:""production"",DEPLOY_ENV:""production"",WEBSOCKET_HOST:void 0,API:""https://api.google.com""}).SERVER_API||""https://api.google.com""},defaults:{host:""https://api.google.com"",method:""GET""}}}],v=g,O=[{settings:[""master""],routes:";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}