use strict;
my $str = '0,NODE_ENV:"production",DEPLOY_ENV:"production",WEBSOCKET_HOST:void 0,API:"https://api.google.com"}).SERVER_API||"https://api.google.com"},defaults:{host:"https://api.google.com",method:"GET"}}}],v=g,O=[{settings:["master"],routes:';
my $regex = qr/(?<!:\/\/)([a-zA-Z0-9-_]+\.)*[a-zA-Z0-9][a-zA-Z0-9-_]+\.[a-zA-Z]{2,11}/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}