re = /(?<!:\/\/)([a-zA-Z0-9-_]+\.)*[a-zA-Z0-9][a-zA-Z0-9-_]+\.[a-zA-Z]{2,11}/mx
str = '0,NODE_ENV:"production",DEPLOY_ENV:"production",WEBSOCKET_HOST:void 0,API:"https://api.google.com"}).SERVER_API||"https://api.google.com"},defaults:{host:"https://api.google.com",method:"GET"}}}],v=g,O=[{settings:["master"],routes:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end