using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[A-Z]+[a-z]|[a-z]+[A-Z])[a-zA-Z]*";
string input = @"hello 123 worLD";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}