const regex = /\b(?=[A-Z]+[a-z]|[a-z]+[A-Z])[a-zA-Z]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[A-Z]+[a-z]|[a-z]+[A-Z])[a-zA-Z]*', '')
const str = `hello 123 worLD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}