$re = '/\b(?=[A-Z]+[a-z]|[a-z]+[A-Z])[a-zA-Z]*/';
$str = 'hello 123 worLD';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);