#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^[a-zA-Z0-9 @_+\-"\\,.\/]+$"
Local $sString = "B. Bala Manigandan" & @CRLF & _
"B.Balamanigandan" & @CRLF & _
"B. Balamanigandan" & @CRLF & _
"G.S. Sakthivel" & @CRLF & _
"G. S. Sakthivel" & @CRLF & _
"Sakthivel M.G." & @CRLF & _
"GS Sakthivel" & @CRLF & _
"G.S. SAKTHIVEL" & @CRLF & _
"BALA MANIGANDAN .B" & @CRLF & _
"Sakthivel .M.G" & @CRLF & _
"#2675, Gf, Sector 23, Gurgaon" & @CRLF & _
"2675, Sec 23, Gurgaon" & @CRLF & _
"Nagaratnam s/o Suppiah."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")