const regex = /^[a-zA-Z0-9 @_+\-"\\,.\/]+$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9 @_+\\-"\\\\,.\\\/]+$', 'i')
const str = `B. Bala Manigandan
B.Balamanigandan
B. Balamanigandan
G.S. Sakthivel
G. S. Sakthivel
Sakthivel M.G.
GS Sakthivel
G.S. SAKTHIVEL
BALA MANIGANDAN .B
Sakthivel .M.G
#2675, Gf, Sector 23, Gurgaon
2675, Sec 23, Gurgaon
Nagaratnam s/o Suppiah.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}