#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-z\d_\-\[\]^\\{}|`]{1,32}"
Local $sString = "luke" & @CRLF & _
"zarthus" & @CRLF & _
"`zarthus" & @CRLF & _
"[thus]" & @CRLF & _
"hihihi" & @CRLF & _
"test-case"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")