$re = '/[a-z\d_\-\[\]^\\\\{}|`]{1,32}/';
$str = 'luke
zarthus
`zarthus
[thus]
hihihi
test-case';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);