using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z\d_\-\[\]^\\{}|`]{1,32}";
string input = @"luke
zarthus
`zarthus
[thus]
hihihi
test-case";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}